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Introduction 
How to Use this Document 
This document introduces prospective researchers to SPSS for Mac OS, which 
currently runs only under Mac OS X 10.6 or higher. Those who do not own a personal 
copy of SPSS for Mac OS X may access the software from various UITS Student 
Technology Centers at IU. Under the SPSS Enterprise License Agreement, faculty, 
staffs, and students can purchase SPSS CD for use at home. 

What is SPSS? 
SPSS is a comprehensive and flexible statistical analysis and data management 
system. SPSS can take data from almost any type of file and use them to generate 
abulated reports, charts, and plots of distributions and trends, descriptive statistics, 
and conduct complex statistical analyses. SPSS is available on Windows and Mac OS 
X on Indiana University campus. The latest version for Mac OS X is only available 
under OS X 10.6 or higher. 

SPSS for Mac OS X provides a user interface that makes statistical analysis more 
intuitive for all levels of users. Simple menus and dialog box selections make it 
possible to perform complex analyses without typing a single line of command syntax. 
The built-in SPSS Data Editor offers a simple and efficient spreadsheet-like utility for 
entering data and browsing the working data file. High-resolution, presentation-quality 
charts and plots can be created and edited. Using the SPSS Viewer, you can handle 
the output with greater flexibility. SPSS for Mac OS X also reads data files from a 
variety of file formats including Excel, SAS, and Stata. 

Hardware and Software Requirements 
The minimum hardware and software requirements for SPSS for Mac OS X are: 

• OS X 10.6 or higher 
• Intel processor 
• 1 GB RAM or more 
• 800 MB free harddisk space 
• DVD-ROM drive 
• Super VGA (1024x768) or a high resolution monitor 



Orientation 
Windows in SPSS 
There are a number of different types of windows that you will see in SPSS for Mac 
OS: 

Data Editor window 
This window displays the contents of the data file. You may create new data 
files, or modify existing ones with Data Editor. The Data Editor window opens 
automatically when you start a new SPSS session. 

Viewer window 
The Viewer window displays the statistical results, tables, and charts from the 
analysis you performed (e.g., descriptive statistics, correlations, plots, charts). 
A Viewer window opens automatically when you run a procedure that 
generates output. In the Viewer windows, you can edit, move, delete and copy 
your results in the Finder. 

Pivot Table Editor window 
Output displayed in pivot tables can be modified in many ways with the Pivot 
Table Editor. You can edit text, swap data in rows and columns, add color, 
create multidimensional tables, and selectively hide and show results. 

Chart Editor window 
You can modify and save high-resolution charts and plots by invoking the Chart 
Editor for a certain chart (by double-clicking the chart) in a Viewer window. You 
can change the colors, select different type fonts or sizes, switch the horizontal 
and vertical axes, rotate 3-D scatterplots, and even change the chart type. 

Text Output Editor window 
Text output not displayed in pivot tables can be modified with the Text Output 
Editor. You can edit the output and change font characteristics (type, style, 
color, size). 

Syntax Editor window 
You can paste your dialog box selections into a Syntax Editor window, where 
your selections appear in the form of command syntax. You can then edit the 
command syntax to utilize special features of SPSS not available through 
dialog boxes. If you are familiar with SPSS software under other operating 
systems (e.g., Windows), you can open up a Syntax Editor window and enter 
SPSS commands exactly as you did under those platforms and execute the 
job. You can open multiple syntax windows and the contents of a Syntax Editor 
window may be saved for later use. 

Script Editor window 
Scripting (e.g., Python programming language) allows you to customize and 
automate many tasks in SPSS. Use the Script Editor to create and modify basic 
scripts. 



Menus in SPSS for Mac OS 
Many of the tasks you want to perform with SPSS start with menu selections. Each 
window in SPSS has its own menu bar with menu selections appropriate for that 
window type. The Data Editor window, for example, has the following menu with its 
associated toolbar: 

 

Most menus are common for all windows and some are found in certain type of 
windows. 

Common menus 
File 

Use the File menu to: Create a new SPSS system file, open an existing system 
file, read in spreadsheet or data files created by other software programs (e.g., 
SAS or Stata), read in an external ASCII data file from the Data Editor; create a 
command file, retrieve an already created SPSS command file into the Syntax 
Editor; open, save, and print output files from the Viewer and Pivot Table 
Editor; and save chart templates and export charts in external formats in the 
Chart Editor, etc. 

Edit 
Use the Edit menu to: cut, copy, and paste data values from the Data Editor; 
modify or copy text from the Viewer or Syntax Editor; copy charts for pasting 
into other applications from the Chart Editor, etc. 

View 
Use the View menu to: turn toolbars and the status bar on and off, and turn grid 
lines on and off from all window types; and control the display of value labels 
and data values in the Data Editor. 

Analyze 
This menu is selected for various statistical procedures such as 
crosstabulation, analysis of variance, correlation, linear regression, and factor 
analysis. 

Graphs 
Use the Graphs menu to create bar charts, pie charts, histograms, scatterplots, 
and other full-color, high-resolution graphs. Some statistical procedures also 
generate graphs. All graphs can be customized with the Chart Editor. 

Utilities 



Use the Utilities menu to: display information about variables in the working 
data file and control the list of variables from all window types; change the 
designated Viewer and Syntax Editor, etc. 

Window 
Use the Window menu to switch between SPSS windows or to minimize all 
open SPSS windows. 

Help 
This menu opens a standard Help window containing information on how to use 
the many features of SPSS. Context-sensitive help is available through the 
dialog boxes. 

Data Editor specific menus 
Data 

Use the Data menu to make global changes to SPSS data files, such as 
transposingvariables and cases, or creating subsets of cases for analysis, and 
merging files. These changes are only temporary and do not affect the 
permanent file unless you save the file with the changes. 

Transform 
Use the Transform menu to make changes to selected variables in the data file 
and to compute new variables based on the values of existing ones. These 
changes are temporary and do not affect the permanent file unless you save 
the file with changes. 

Viewer specific menus 
Insert 

Use the Insert menu to change the page breaks. 
Format 

Use the Format menu to change font characteristics, underline, and bold. 
Pivot Table Editor specific menus 
Insert 

Use the Insert menu to insert titles, captions, and footnotes; and to create table 
breaks. 

Pivot 
Use the Pivot menu to perform basic pivoting tasks, to turn pivoting trays on 
and off, and to go to specific layers in a multidimensional pivot table. 

Format 
Use the Format menu to modify table and cell properties; to apply and change 
TableLook formats; and to change font characteristics, footnote markers, and 
the width of data cells. 

Chart Editor specific menus 
Options 

Use the Options menu to change x/y reference line and add title. 
Elements 

Use the Elements menu to add a fitted regression line in a scatter plot. 
Text Output Editor specific menu 
Insert 



Use the Insert menu to change the page breaks. 
Format 

Use the Format menu to change font characteristics, underline, and bold. 
Syntax Editor specific menu 
Run 

Use the Run menu to run the selected commands. 
Script Editor specific menu 
Macro 

Use the Macro menu to run your code. 
Debug 

Use the Debug menu to step through your code, executing one line or 
subroutine at a time and viewing the result. You can also insert a break point in 
tht script to pause the execution at the line that contains the break point. 

Toolbars in SPSS for Mac OS 
Each SPSS window has its own toolbar that provides quick and easy access to 
common tasks. ToolTips provide a brief description of each tool when you put the 
mouse pointer on the tool. For example, the toolbar with Syntax Editor window shows 
the following tooltip when the mouse pointer is put on the Opne syntax document icon: 

 

Status Bar in SPSS for Mac OS 

 

A status bar at the bottom of the SPSS application window indicates the current status 
of the SPSS processor. If the processor is running a command, it displaysthe 
command name and a case counter indicating the current case number being 
processed. When you first begin an SPSS session, the status bar displays the 
message Starting SPSS Processor. When SPSS is ready, the message changes 
to SPSS Processor is ready. The status bar also provides information such as 
command status, filter status, weight status, and split file status. The followingstatus 
bar in an Viewer window, for example, shows that the current Viewer window is the 
designated output window and the SPSS is ready to run: 



Options in SPSS for Mac OS 
You can personalize your SPSS session by altering the default Opitons settings. 

• Select SPSS Statistics/Preferences 

 

• Click the tabs for the settings you want to change. 
• Change the settings. 
• Click OK or Apply. 

For example, within variable list boxes in dialogs, you have the option to display the 
variable name as always or the variable label (up to 255 characters) can be displayed. 



• Click General from the Options dialog box 
• Click either Display labels or Display names under the Variable Lists 
• Click OK 

Preparing Your Data for 
Analysis 
Organizing Your Data for Analysis 
Suppose you have three test scores collected from a class of 10 students (5 males, 
and 5 females) during a semester. Each student was assigned an identification 
number. The information for each student you have is an identification number, gender 
of each student, and scores for test one, test two, and test three (the full data set is 
displayed toward the end of this section for you to view). Your first task is to present 
the data in a form acceptable to SPSS for processing. 

SPSS uses data organized in rows and columns. Cases are represented in rows and 
variables are represented in columns. 

Name Test1 Test2 Test3 
Tim 20 23 24 
Hans 21 26 28 

A case contains information for one unit of analysis (e.g., a person, an animal,a 
machine). Variables are information collected for each case, such as name, score, 
age, income, educational level. In the above chart, there are two cases and four 
variables. When data in files are arranged in rows and columns (as shown above), it is 
called cases-by-variables, or rectangular data files. 

In SPSS, variables are named with eight or fewer characters. They must begin with a 
letter, although the remaining characters can be any letter, any digit, a period, or the 
symbols (@, #, _, or $). Variable names cannot end with a period. Variable names 
that end with an underscore should be avoided. Blanks and special characters such 
as &, !, ?, ‘, and * cannot be used in a variable name. Variable names are not case 
sensitive. Each variable name must be unique; duplication is not allowed. 

Most variables are generally numeric (e.g., 12, 93.23) or 
character/string/alphanumeric (e.g., F, f, john) in type. Maximum width for numeric 
variables is 40 characters, the maximum number of decimal positions is 16. String 
variables with adefined width of eight or fewer characters are short strings, more than 
eight characters (up to 255 characters) are long strings. Short string variables can be 
usedin many SPSS procedures. You may leave a blank for any missing numeric 



values or enter a user-missing (e.g., 9, 999) value. However, for string values a blank 
is considered a valid value. You may choose to enter a user-missing (e.g.,x, xxx, na) 
value for missing short string variables, but long string variables cannot have user-
missing values. 

Following the conventions above, let us assign names for the variables in our data set: 
id, sex, test1, test2, and test3. Once the variables are named according to SPSS 
conventions, it is a good practice to prepare a code book with details of the data 
layout. Following is a code book for the data in discussion. Note that this step is to 
present your data in an organized fashion. It is not mandatory for data analysis. A 
code book becomes especially handy when dealing with large number of variables. A 
short sample data, like the following, may not need a code book, but it is included for 
illustration. 

  var. name      width      columns     var. type     var. 
labels       id            2          8           Numeric      
identification no.       sex           1          8           
String       student gender (f, m)       test1         2          
8           Numeric      test one score       test2         2          
8           Numeric      test two score       test3         2          
8           Numeric      test three score   

In the above code book, width stands for the number of fields/columns taken by each 
variable. For example, the value for variable id takes a maximum of two fields since 
the highest identification number in our example is going to be 10. The value for 
variable sex takes a maximum of one field, and so on. Columns affect only the 
display of values in the Data Editor. Changing the column width does not change the 
defined width of a variable. Var. type specifies the data type (numeric, comma, dot, 
scientific notation, date, custom currency or string). In our example, sex is the only 
string variable coded as f for female, m for male. 

The next issue is entering your data into the computer. There are several options. You 
may create a data file using one of your favorite text editors (e.g., TextEdit). Files 
created using word processing software should be saved in text format before trying to 
read them into an SPSS session. You may enter your data into a spreadsheet (e.g., 
Excel) and read it directly into SPSS for Mac OS. Finally,you may enter the data 
directly into the spreadsheet-like Data Editor of SPSS for Mac OS. In this document 
we are going to examine two of the above data entry methods: using a text editor, and 
using the Data Editor of SPSS for Mac OS. 

Using an Editor to Enter Data 
Let us first look into the steps for using a text editor for entering data. Note that if you 
have a data set with a limited number of variables, you may want to use the Data 
Editor to enter your data. However, this example is for illustration purposes. Open up 
your editor session, or word processing session, and enter the variable values into 



appropriate columns as outlined in the code book. Your completed data file will appear 
as follows. (Note: The first line is included as a column marker line and is not part of 
the data. It must be removed before saving or using the data for analysis.) 

     12345678901234567890       01 f 83 85 91       02 f 65 72 
68       03 f 90 94 90       04 f 87 80 82       05 f 78 86 80       
06 m 60 74 64       07 m 88 96 92       08 m 84 79 82       09 
m 90 87 93       10 m 76 73 70   

Save the data as a text file named, grade.dat onto a flash drive or onto the hard drive. 

Notice in the above data layout that one blank space is left after each variable as 
specified in the code book. It is optional whether to leave a space between variable 
values. For example, you may choose to enter the data as following: 

     01f838591       02f657268       03f909490       04f878082       
05f788680       06m607464       07m889692   
Whichever style (format) you choose, as long as you convey the format correctly to 
SPSS, it should not have any impact on the analysis. In the above layout, each 
case/observation has only one line (record) of data. In another situation you may have 
multiple records per observation. 

Creating a Command file to read in your 
data 
In many instances, you may have an external ASCII data file made available to you for 
analysis, just like the data, grade.dat, we discussed earlier. In such asituation, you do 
not have to enter your data again into the Data Editor. You can direct SPSS to read 
the file from the Syntax Editor window. 

Suppose you want to read the file, grade.dat, into SPSS from a Syntax 
Editor window and create a system file – as you did with the previous data 
(sample.sav) by using the Data Editor. Creating a command file is a faster way to 
defineyour variables, especially if you have a large number of variables. You may 
create a command file using your favorite editor and then read it into a Syntax 
Editor window or open a Syntax Editor window and type in the command lines. 

To read your already created command file into a Syntax Editor window 

• Select File/Open/Syntax… 
• Choose the syntax file you want to read and click Open 

In the following example we are opening a new Syntax Editor window to enter the 
following command lines. 

• Select File/New/Syntax 



When the Syntax Editor window appears, type: 

     DATA LIST FILE=’/Users/myuser/Desktop/grade.dat’ FIXED         
/ id 1-2 sex 4 (A) test1 6-7 test2 9-10 test3 12-13.       
EXECUTE.       SAVE OUTFILE=’/Users/myuser/Desktop/sample.sav’.   

Click and drag with your mouse to highlight the lines entered, then click Run and 

choose selection. Alternatively, you can click  from the toolbar 

The command file will read the specified variable values from the data file, grade.dat, 
on diskette, and create a system file, sample.sav, on diskette. Make sure you specify 
the pathname appropriately indicating the location of the external data file and where 
the newly created file is to be written. However, you donot have to save a system file 
to do the analysis. This means the last line is optional for data analysis. Every time 
you run the above lines, SPSS does create an active file stored in the computer’s 
memory. However, for large data sets, itwill save processing time if you save it as a 
system file and access it for analysis. 

In the above command lines, DATA LIST defines a raw data file by assigning names 
and formats to each variable in the file. They can be in fixed format (valuesfor the 
same variable are always entered in the same location on the same recordfor each 
case) or in freefield format (values for consecutive variables are notin particular 
columns but are entered one after the other, separated by blanks orcommas). In our 
example, we used the fixed format. FIXED is the default if no format is specified. That 
is, in our example we did not have to use the FIXED keyword, but it is included for the 
sake of illustration. The only string variable in the data is sex, which is identified with a 
(A) after the variable name and column location. 

We do not have any numeric variables with decimal places. SPSS assumes that 
decimal points are explicitly coded in the data file. If there are no decimal points, the 
numeric variables are assumed to be integers. To indicate noninteger values for data 
that have not been coded with decimal points, specify the implied number of decimal 
places in parentheses after the variable name and column locationas in gpa 16-18 (2). 
This means the variable gpa is in columns 16-18 and is recorded as, for example, 
389, and it will be assigned 3.89 by SPSS. 

Inline data 
In the above example your data are being read from an external file, grade.dat, on 
drive A. Still another option is to keep the data within the command file. Insuch an 
instance you direct SPSS to read your inline data from the command lines with the 
BEGIN DATA and END DATA commands. In this mode of data input you willomit the 
FILE subcommand from the DATA LIST command. The BEGIN DATA command 
follows the DATA LIST command, and the END DATA command follows the last line 
of data. All procedure commands should come after the END DATA command, but 



transformation commands can be specified before BEGIN DATA. For example, if you 
want to read the above data file, grade.dat, as inline data, you should modify the 
above command lines as following: 

DATA LIST FREE     / id * sex (a) test1 test2 test3.  BEGIN 
DATA.  01 f 83 85 91  02 f 65 72 68  03 f 90 94 90  04 f 87 80 
82  05 f 78 86 80  06 m 60 74 64  07 m 88 96 92  08 m 84 79 82  
09 m 90 87 93  10 m 76 73 70  END DATA.  EXECUTE.  SAVE OUTFILE 
='/Users/myuser/Desktop/sample.sav'.   

In this example, we used a FREE format data layout for illustration. Each variable 
value is separated by a blank space. Since we are using free format, the column 
specification, after each variable, is dropped. Note that the variable sex is a one-
character string variable. In free field format, when you specify a string format, that 
format applies to all preceding variables. This means SPSS will regard both id and sex 
to be read with the string format. To avoid this, place an asterisk (*) after the variable 
id, to convey that id must be read with the default numeric format. FIXED format can 
be used with inline data. You may type the above lines in to a Syntax Editor window, 
or read in the text file with inline data into a Syntax Editor window and execute it as 
explained above. Keeping data inline may not be an efficient option when you have a 
large number of data lines. 

Using Text Import Wizard to Read Text 
Data 
Using Text Import Wizard is another way to direct SPSS to read an external ASCII 
data file. 

Suppose you want to read the file, grade.dat, into SPSS from Text Import Wizard. 

• Select File/Open 
• Click Text(*.txt, *dat, *csv) for the Files of type from the Open File dialog box, 

choose the data file grade.dat on your computer, and click Open 
• Text Import Wizard is open, follow the Step1 to Step6 in this wizard to specify 

how the data should be read. 

In the following example we are opening grade.dat. 

• Step 1 of 6: Check ‘no’ in ‘Does your text file match a predefined format?’ and 
click Continue. 

• Step 2 of 6: Check ‘Fixed width’ in ‘How are your variables arranged?’, check 
‘No’ in ‘Are variable names included at the top of your file?’ and click Continue. 

• Step 3 of 6: Keep all default checks and click Next. 
• Step 4 of 6: Insert breaks to specify the variables begin. Then click Continue. 



• Step 5 of 6: This step is for specifications of variables selected in the data 
preview. Click V1, the column highlight. Type id in the Variable name dialog 
box, type numeric in the Data format dialog box. As the same way, change V2, 
V3, V4, V5 into sex, test1, test2, test3,respectively. 
Only sex is string variable. click Continue. 

• Step 6 of 6: Keep all default checks and click Done. 

The data file is read into the SPSS. We can save the data file as sample.sav. 

Using the SPSS Data Editor for entering 
data 
Suppose you want to use the SPSS for Mac OS X features for data entry. In that case, 
you enter data directly into the SPSS spreadsheet-like Data Editor. This is convenient 
if you have only a small number of variables. The first step is to enter the data into the 
Data Editor window by opening an SPSS for Mac OS X session. You will define your 
variables, variable type (e.g., numeric,alphanumeric), number of decimal places, and 
any other necessary attributes while you are entering the data. In this mode of data 
entry, you must define each variable in the Data Editor. You cannot define a group of 
variables (e.g., Q1 to Q10) using the Data Editor. To define a group of variables, 
without individually specifying them, you would use the Syntax window. 

Let us start an SPSS for Mac OS X session to enter the above data set. If you are 
using your own Mac OS X, start Mac OS X and launch SPSS. 

This opens the SPSS Data Editor window (titled Untitled). The Data Editor window 
contains the menu bar, which you use to open files, choose statistical procedures, 
create graphs, etc. When you start an SPSS session, the Data Editor window always 
opens first. 

You are ready to enter your data once the Data Editor window appears. The first step 
is to enter the variable names that will appear as the top row of the data file. When 
you start the session, the top row of the Data Editor window contains a dimmed var as 
the title of every column, indicating that no data are present. In our sample data set, 
discussed above, there are five variables named earlier asid, sex, test1, test2, 
and test3. Let us now enter these variable names into the Data Editor. To define the 
variables, click on the Variable View tab at the lower left corner of the Data Editor 
window and: 

• Type in the variable name, id, at the first row under the column Name. 
• Press the Tab key to fill-in the variable’s attributes with default settings. 



SPSS considers all variables as numeric variables by default. Since id is a numeric 
variable you do not have to redefine the variable type for id. However, you may want 
to change the current format for decimal places. 

• Enter 0 for Decimals. 

Now let us define the second variable, sex. 

• Type in the variable name, sex, at the second row under the column Name. 
• Press the Tab key to fill-in the variable’s attributes with default settings. 

• To modify the variable type, click on the  icon in the Type column. 
• Select String by clicking on the circle to the left. 

Define the remaining three numeric variables, test1, test2, and test3, the same way 
the variable idwas defined. Once you have finished, the Variable View screen should 
look like: 

 

Click on the Data View tab. Now enter the data pressing the tab key or the right arrow 
key after each entry. After entering the last variable value for case number one use 
the arrow key to move the cursor to the beginning of the next line. Continue the 
process until all the data are entered. 

Saving Your SPSS Data 
After you have entered/read the data into the Data Editor, save it onto a flash drive. 
Those who are working from personally owned computers might want to save the file 
to the hard disk. 

• Select Save… or Save As… from the File menu. A dialog box appears. 



 

• Fill the File name box that you want to save and choose SPSS Statistics as 
Save as type. 

• Click Save 

The data will be saved as an SPSS format file. Note that the data file, grade.dat, you 
saved earlier and the file, sample.sav, you saved now are in different formats. 

Even after saving the data file, the data will still be displayed on your screen. If not, 
selectsample.sav-SPSS Data Editor from the Window menu. 

Descriptive Data Analysis 
Suppose that you have the data set, sample.sav, still displayed on your screen. If not, 
selectsample.sav - SPSS Data Editor from the Window menu. (If you used 
the Syntax Editor window to read in your data file, grade.dat, then also make 
the sample.sav - SPSS Data Editor window active.) 

The next step is to run some basic statistical analysis with the data you entered. The 
commands you use to perform statistical analysis are developed by simply pointing 
and clicking the mouse to appropriate menu options. This frees you from typing in your 
command lines. 

However, you may paste the command selections you made to a Syntax 
Editor window. The command lines you paste to the Syntax Editor window may be 



edited and used for subsequent analysis, or saved for later use. Use 
the Paste pushbutton to paste your dialog box selections into aSyntax Editor window. 
If you don’t have an open Syntax Editor window, one opens automatically the first 
time you paste from a dialog box. Click the Paste button only if you want to view the 
command lines you generated. Once you click the Paste pushbutton the dialog 
selections are pasted to theSyntax Editor window, and this window becomes active. 
To execute the pasted command lines, highlight them and click run. You can always 
get back to the Data Editor window by selectingsample.sav - SPSS Data Editor from 
the Window menu. 

Computing a New Variable 
Before computing the descriptive statistics, we want to calculate the mean scorefrom 
the three tests for each student. To compute the mean score: 

• Select Compute Variable… from the Transform menu. A dialog box appears 

 



• In the box below the Target Variable: type in average as the variable name 
you want to assign to the mean score 

• Move the pointer to the box titled Numeric Expression: and type: mean (test1, 
test2, test3) 

• Click OK 

A new column titled average will be displayed in the Data Editor window with the 
values of the mean score for each case. 

FREQUENCIES 
To run the FREQUENCIES procedure: 

• Select Descriptive Statistics from Analyze menu 
• Choose Frequencies… 
• A dialog box appears. Names of all the variables in the data set appear on the 

left side of the dialog box. 

 

• Select the variable sex from the list. It is highlighted. 
• Click the arrow button right to the selected variable. 

Now the selected variable appears in a box on the right and disappears from the left 
box. Note that when a variable is highlighted in the left box, the arrow button is pointed 
right for you to complete the selection. When a variable is highlighted in t 



he right box, the arrow button is pointed left to enable you to deselect a variable (by 
clicking the button) if necessary. If you need additional statistics besides the frequency 
count, click theStatistics… button at the bottom of the screen. When 
the Statistics… dialog box appears, make appropriate selections and click Continue. 
In this instance, we are interested only in frequency counts. 

• Click OK 

The output appears on the Viewer screen 

 

DESCRIPTIVES 
Our next task is to run the DESCRIPTIVES procedure on the four continuous 
variables in the data set. 

• Select Descriptive Statistics from the Analyze menu 
• Choose Descriptives… 

A dialog box appears. Names of all the numeric variables in the data set appear on 
the left side of the dialog box. 



 

• Click the variable average and click the arrow button to the right of the selected 
variable 

• Do the same thing for the variables test1 through test3 

Now the selected variables appear in the box on the right and disappear from the box 
on the left. 

The mean, standard deviation, minimum, and maximum are displayed by default. The 
variables are displayed, by default, in the order in which you selected them. 
Click Options… for other statistics and display order. 

• Click OK 

The following output will be displayed on the Viewer screen. 



 

MEANS 
Suppose you want to obtain the above results for males and females separately. The 
MEANS procedure displays means, standard deviations, and group counts for 
dependent variables based on grouping variables. In our data set sex is the grouping 
variable and test1, test2, test3, and averageare the dependent variables. Before 
proceeding with the analysis let us clear the output window to better view the output 
from the MEANS procedure and later print it out. To do so, make the Viewerwindow 
active (select Output1 - SPSS Viewer from the Window menu). 

• Choose Edit/Select All 
• Select Edit/Delete 

To run the MEANS procedure: 

• Select Analyze/Compare Means/Means… 
• Select test1, test2, test3, and average as the dependent variables 
• Select sex as the independent variable 



 

• Click Options… 



 

• Select Mean, Number of cases, and Standard Deviation. Normally these 
options are selected by default. If any other options are selected, deselect them 
by clicking them 

• Click Continue 
• Click OK 

The output will be displayed on the Viewer screen. 



 

There may be other situations in which you want to select a specific category of cases 
from a grouping variable (e.g., ethnic background, socio-economic status, education). 
To do so, chooseData/Select Cases… to select the cases you want and do the 
analysis (e.g., from the grouping variable educate, select cases without a college 
degree). However, make sure you reset your data if you want to include all the cases 
for subsequent data analysis. If not, only the selected cases will appear in subsequent 
analysis. To reset your data choose Data/Select Cases…/All Cases, and clickOK. 

 



SPSS Output 
Working with Output 
When you run a procedure in SPSS, the results are displayed in the Viewer window in 
the order in which the procedures were run. In this window, you can easily navigate to 
whichever part of output you want to see. You can also manipulate the output and 
create a document that contains precisely the output you want, arranged and 
formatted appropriately. You can use the Viewer to: 

• Browse output results or show or hide selected tables and charts 
• Change the display order of output by moving selected items 
• Access the Pivot Table Editor, Text Output Editor, or Chart Editor for 

modifying output 
• Move items between SPSS and other applications 

The Viewer is divided into two panes. The left pane contains an outline view of the 
output contents. The right pane contains statistical tables, charts, and text output. You 
can use the scroll bars to browse the results, or you can click an item in the outline to 
go directly to the corresponding table or chart. 

Suppose you want to copy the Descriptives table into another Mac OS application, 
such as a word processing program or a spreadsheet. 

• Click the Descriptives table 

 



• Select Edit/Copy 
• Switch to target application 
• From the menus in the target application you can choose 

either Edit/Paste or Edit/Paste Special… 
• If you choose Edit/Paste Special… select the type of object you want to 

paste Edit/Paste Special… allows you to paste the SPSS output as an 
embedded object into the target application. 

Manipulating Pivot Tables 
Much of the output in SPSS is presented in tables that can be pivoted interactively. 
You can rearrange the rows, columns, and layers. To edit a pivot table, double-click 
the pivot table. Or click on the table you are going to edit, then click Edit/Edit Content/In 
Seperate Window. The pivot table will be ready to edit in its own separate Pivot Table 
Editor window. 

 
 

Further Data Analysis 
So far, we’ve used SPSS to develop a basic idea about how SPSS for Mac OS X 
works. Next step is to examine a few other data analysis techniques 



(CORRELATIONS, REGRESSION, T-TEST, ANOVA). Refer to the vendor 
documentation for the most complete information. 

Sample Data Set 
Now we will turn to another data set with more variables and cases. In this example, 
you will read an ASCII data file, clas.dat, created with a word processor and saved as a 
text file into the SPSS session. The data collected from 40 middle school students 
contains 26 variables including the following: 

id (student identification number) sex (gender of the student) exp (previous computer 
experience in months/yrs) school (name of school system) C1 thru C10 (10 scores on 
the computer anxiety scale)M1 thru M10 (10 scores on the math anxiety 
scale) mathscor (math score for the same testing period) compscor (computer test 
score for a given testing period) 

The first four variables (id, sex, exp, school) are background variables. The variable 
sex has two levels (M=male, F=female). Exp (prior computer experience) has three 
levels (1=less than one year, 2=1-2 years, 3=more than 2 years), school (type of 
school system) has three levels (1=rural, 2=suburban school, 3=urban school). The 
next 20 variables (C1..C10, M1..M10) are Likert type responses to computer opinion 
and math anxiety surveys. The remaining variables (mathscor, compscor) are scores 
on the math test and computer test. 

A copy of the sample data file is available from the Stat/Math Web home page. 

Creating a Program to Read the Data File 
Let us assume that the data file, clas.dat, is on your Desktop. The fastest way to read 
this data into SPSS for Mac OS X is using the Syntax window. You may open a Syntax 
Editor window (File/New/Syntax) and type in the following lines. 

  DATA LIST FILE='/Users/mysuer/Desktop/clas.dat' /id 1-2 sex 3 
(A) exp 4 school 5 c1 to c10 6-15 m1 to m10 16-25 mathscor 26-
27 compscor 28-29. MISSING VALUES mathscor compscor (99). 
RECODE c3 c5 c6 c10 m3 m7 m8 m9 (1=5) (2=4) (3=3) (4=2) (5=1). 
RECODE sex ('M'=1) ('F'=2) INTO nsex. /* char var into numeric 
var COMPUTE compopi=SUM (c1 TO c10). /* find sum of 10 items 
using sum function  COMPUTE 
mathatti=m1+m2+m3+m4+m5+m6+m7+m8+m9+m10. /* adding each item 
VARIABLE LABELS id 'Student Identification' sex 'Student 
Gender' exp 'Yrs of Comp Experience' school 'School 
Representing' mathscor 'Score in Mathematics' compscor 'Score 
in Computer Science' compopi 'Total for Comp Survey' mathatti 
'Total for Math Atti Scale'. VALUE LABELS sex 'M' 'Male' 'F' 



'Female'/ exp 1 'Up to 1 yr' 2 '2 years' 3 '3 or more'/ school 
1 'Rural' 2 'City' 3 'Suburban'/ c1 TO c10 1 'Strongly 
Disagree' 2 'Disagree'3 'Undecided' 4 'Agree' 5 'Strongly 
Agree'/ m1 TO m10 1 'Strongly Disagree' 2 'Disagree' 3 
'Undecided' 4 'Agree' 5 'Strongly Agree'/ nsex 1 'Male' 2 
'Female'. EXECUTE.  
Use the mouse to highlight the command lines and click Run. The command lines will 
be executed and an active SPSS file will be created. Select Window/Untitled - IBM 
SPSS Statistics Data Editorto see the data file you just read in. Save the data file as 
an SPSS system file to a USB drive or to a hard drive. 

• Select File/Save 
• Type in a filename (e.g., clas.sav) 
• A copy of the file will now be saved in SPSS format. Now you are ready for 

further data analysis. 

Correlation analysis 
A correlation analysis is performed to quantify the strength of association between two 
numeric variables. In the following task we will perform Pearson correlation analysis. 
The variables used in the analysis are compopi, mathatti, mathscor and compscor. 

• Select Analyze/Correlate/Bivariate… This opens the Bivariate 
Correlations dialog box. The numeric variables in your data file appear on the 
source list on the left side of the screen. 

• Select compopi, compscor, mathatti and mathscor from the list and click the 
arrow box. The variables will be pasted into the selection box. The 
options Pearson and Two-tailed are selected by default. 



 

• Click OK 

A symmetric matrix with Pearson correlation as given below will be displayed on the 
screen. Along with Pearson r, the number of cases and probability values are also 
displayed. 



 

Simple Linear Regression 
A correlation coefficient tells you that some sort of relation exists between the 
variables, but it does not tell you much more than that. For example, a correlation of 
1.0 means that all points fall exactly on a straight line, but it says nothing about the 
form of the relation between the variables. When the observations are not perfectly 
correlated, many different lines may be drawn through the data. To select a line that 
describes the data, as close as possible to the points, you employ the Regression 
Analysis which is based on the least- squares principle. In the following task you will 
perform a simple regression analysis with compscor as the dependent variable, 
and mathscor as the independent variable. 

• Choose Analyze/Regression/Linear… The Linear Regression dialog box 
appears. 

• Choose compscor as the dependent variable 
• Choose mathscor as the independent variable 



 

• Click OK 

The output will now be displayed on the screen as shown below: 



 

T-test 
T-test is a data analysis procedure to test the hypothesis that two population means 
are equal. SPSS can compute independent (not related) and dependent (related) t-
tests. For independent t-tests, you must have a grouping variable with exactly two 
values (e.g., male and female, pass and fail). The variable may either be numeric or 



character. Suppose you have a grouping variable with more than two categories. You 
may use the RECODE command to collapse the categories into two groups. For 
example, a variable, exp, has 3 categories. You want to collapse this into two 
categories (1 = < 1 yr. exp, 2 = one or more yrs.) and create a new variable, newexp. 
The syntax is: 

RECODE exp (1 = 1) (2,3 = 2) INTO newexp.  EXECUTE.  

RECODE is a powerful SPSS command for data transformation with both numeric and 
string variables. In the following task, we will perform an independent t-test. The test 
variables aremathscor and compscor, and the grouping variable is newexp. 

• Select Analyze/Compare Means/Independent-Samples T Test… 
• Select compscor, and mathscor as the Test Variables 
• Select newexp as the Grouping Variable. 

 

• Click on Define Groups… 
• Type 1 for Group 1, and 2 for Group 2. 



 

• Click Continue 
• Click OK 

The output will now be displayed on the screen as shown below: 

 

One-way Analysis of Variance 
The statistical technique used to test the null hypothesis that several population 
means are equal is called analysis of variance. It is called that because it examines 
the variability in the sample and, based on the variability, it determines whether there 
is a reason to believe the population means are not equal. The statistical test for the 
null hypothesis that all of the groups have the same mean in the population is based 
on computing the ratio of within and between group variability estimates, called the F 
statistic. A significant F value only tells you that the population means are probably not 



all equal. It does not tell you which pairs of groups appear to have different means. To 
pinpoint exactly where the differences are, multiple comparisons may be performed. 

In the following exercise you will perform a One-Way ANOVA with compopi as the 
dependent variable, and exp as the factor variable. 

• Select Analyze/Compare Means/One-Way ANOVA… 
• Select compopi for the dependent variable 
• Select exp for the factor variable 

 

• Click Post Hoc… 
• Select LSD(Least-significant difference) 



 

• Click Continue 
• Click Options… 
• Select descriptive 
• Click Continue 
• Click OK 

The output will be displayed on the screen as shown below: 



 

 

Further Reading 
The material covered in this document illustrates some of the basic features of SPSS 
20 for Mac OS X. Examining additional features of SPSS for Mac OS X is beyond the 
scope of this document. For further help, refer to SPSS 20 documents. If you need 
assistance in using SPSS for Mac OS X, contact the UITS Stat/Math Center. 

The documents for SPSS 20 are: 



• SPSS Brief Guide 20 
• SPSS Statistics Base 20 
• SPSS Command Syntax Reference 20 
• SPSS Advanced Statistics 20 
• SPSS Regression 20 

 


